moshimore Knowledge

アプリ開発・紹介とメモ書き、日々の日記。

はてなブログのSSL証明書が期限切れになりました…!

f:id:moshimore:20180916102552j:plain
ブログのメンテナンスをしようと思って、このブログを開いてみたところ、はてなが管理しているSSL証明書が期限切れになっていました…!

障害・メンテナンス情報

はてなブログの障害・メンテナンス情報には特に情報もなく、これは、このブログ単体でSSL証明書更新(2018/06/18から2018/9/16までの期限)のバッチ処理に落ちたのか…?と思って問い合わせしてみました。

しばらく経って

問い合わせページには、返信必要というチェックボックスがあったので、チェックを入れて送信したのですが、特に連絡もなく以下の通りに更新してくれました!
素早い対応、ありがとうございます!
(もしかしたら、この後、連絡があるかも知れません。)

f:id:moshimore:20180916102612p:plainf:id:moshimore:20180916104854p:plain

気になるのが、2018/08/18から2018/11/16までの期限になったところです。
今日からの更新だとしたら、今日から90日後の有効期限になると思うのですが、内部で何が起こっているのでしょう。
なんとなくですが、はてな内部では証明書の発行から60日後に新しい証明書を更新してるけど、ブログに当て込み忘れたということでしょうか?
Let's Encryptが過去からの期限の証明書を発行してくれないはずですし?

因みに…

この障害・メンテナンス情報ページって、SSLページではありませんでしたか?
今見たところ、「http://maintenance.hatena.ne.jp/」です。

Twitterでも何人か期限になってしまったという報告がありました。
twitter.com